Radiator fan problem?

Easyrider772

New member
Hi went for a ride (8 miles) out in country, but when came back into city, radiator fan came on fairly soon after sitting in traffic. The traffic was very light though but after another 2 miles fan was still on when I got back home? I also find that travelling 3 miles into work in light traffic and the fan comes on when I get to work. No leaks at all - Coolant level is on upper line in reservoir, is this normal? I was thinking perhaps a faulty temperature sensor? Thanks for any help on this.
 

Gizmo

Member
Maybe the coolant needs to be flushed/changed. Possible obstruction in the cooling system is causing higher temps OR the sensor IS bad! (Should be fairly simple to correct) BUT whatever you do, find the problem else you may do 'expensive' damage to the bike!
 

spamer80

Member
Hi went for a ride (8 miles) out in country, but when came back into city, radiator fan came on fairly soon after sitting in traffic. The traffic was very light though but after another 2 miles fan was still on when I got back home? I also find that travelling 3 miles into work in light traffic and the fan comes on when I get to work. No leaks at all - Coolant level is on upper line in reservoir, is this normal? I was thinking perhaps a faulty temperature sensor? Thanks for any help on this.
How clean is your radiator? The dn-01 is very sensitive to that.
If you ride the bike and then let it just idle at around 20c for a few minutes the fan should normally shut off.
 


Top